ftp.delorie.com/archives/browse.cgi   search  
Mail Archives: cygwin-apps/2001/03/15/04:31:28

Mailing-List: contact cygwin-apps-help AT sourceware DOT cygnus DOT com; run by ezmlm
Sender: cygwin-apps-owner AT sourceware DOT cygnus DOT com
List-Subscribe: <mailto:cygwin-apps-subscribe AT sources DOT redhat DOT com>
List-Archive: <http://sources.redhat.com/ml/cygwin-apps/>
List-Post: <mailto:cygwin-apps AT sources DOT redhat DOT com>
List-Help: <mailto:cygwin-apps-help AT sources DOT redhat DOT com>, <http://sources.redhat.com/lists.html#faqs>
Delivered-To: mailing list cygwin-apps AT sources DOT redhat DOT com
To: "Robert Collins" <robert DOT collins AT itdomain DOT com DOT au>
Cc: <cygwin-apps AT sources DOT redhat DOT com>, <autoconf AT gnu DOT org>
Subject: Re: updated win32 macro
References: <035401c0ac91$3ba21fd0$0200a8c0 AT lifelesswks>
<022001c0accf$29b724d0$0200a8c0 AT lifelesswks>
<mv4vgpb5qtc DOT fsf AT nostromo DOT lrde DOT epita DOT fr>
<009901c0ad30$edf3d7b0$0200a8c0 AT lifelesswks>
From: Akim Demaille <akim AT epita DOT fr>
Date: 15 Mar 2001 10:41:27 +0100
In-Reply-To: <009901c0ad30$edf3d7b0$0200a8c0@lifelesswks>
Message-ID: <mv4itlb5pyw.fsf@nostromo.lrde.epita.fr>
Lines: 31
User-Agent: Gnus/5.0808 (Gnus v5.8.8) XEmacs/21.1 (Cuyahoga Valley)
MIME-Version: 1.0

| > My opinion is that AC_PROG_CC_WIN32 should contain an AC_REQUIRE of
| > AC_CANONICAL_HOST, and should ensure the case $host itself.
| 
| Why? 

To make it easier to read and write where it is used.

| There is no side effect if it is tested for on platforms other than
| cygwin. 

Nor in my proposal.  I'm just saying the AC_CANONICAL_HOST and case
should get into it, nothing more.

| And by being a little bit more generic less changes will be
| needed to work with (say) WINE. Or on a cross-compile chain.

We are probably misunderstanding each other.  I don't understand what
you mean here.

| And the developer writing the configure test will still need to decide
| what to do if it fails && they are compiling on cygwin, so they still
| need a case statement.

It was not clear to me that ac_cc_win32 was the main point, I
understood that setting CC was the main point.

So if that's the case, then I have further comments to make.  Don't
use the ac_cc name space at all when interacting with the user.  Use
some upper case thing such as CC_MWIN32.  I have no idea about it, but
I guess the C++ compiler will also want something similar?

- Raw text -


  webmaster     delorie software   privacy  
  Copyright 2019   by DJ Delorie     Updated Jul 2019