ftp.delorie.com/archives/browse.cgi   search  
Mail Archives: cygwin-apps/2001/09/19/08:43:51

Mailing-List: contact cygwin-apps-help AT sourceware DOT cygnus DOT com; run by ezmlm
Sender: cygwin-apps-owner AT sourceware DOT cygnus DOT com
List-Subscribe: <mailto:cygwin-apps-subscribe AT sources DOT redhat DOT com>
List-Archive: <http://sources.redhat.com/ml/cygwin-apps/>
List-Post: <mailto:cygwin-apps AT sources DOT redhat DOT com>
List-Help: <mailto:cygwin-apps-help AT sources DOT redhat DOT com>, <http://sources.redhat.com/lists.html#faqs>
Delivered-To: mailing list cygwin-apps AT sources DOT redhat DOT com
From: "Ralf Habacker" <Ralf DOT Habacker AT freenet DOT de>
To: <cygwin-apps AT cygwin DOT com>
Subject: AW: get windows error message 0xc0000142 on starting cygwin app
Date: Wed, 19 Sep 2001 14:47:43 +0200
Message-ID: <000001c14109$4697d030$651c440a@BRAMSCHE>
MIME-Version: 1.0
X-Priority: 3 (Normal)
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook 8.5, Build 4.71.2173.0
In-Reply-To: <20010919065722.A12960@redhat.com>
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4133.2400
Importance: Normal

> -----Ursprüngliche Nachricht-----
> Von: cygwin-apps-owner AT sourceware DOT cygnus DOT com
> [mailto:cygwin-apps-owner AT sourceware DOT cygnus DOT com]Im Auftrag von
> Christopher Faylor
> Gesendet am: Mittwoch, 19. September 2001 12:57
> An: cygwin-apps AT cygwin DOT com
> Betreff: Re: get windows error message 0xc0000142 on starting cygwin app
>
> On Wed, Sep 19, 2001 at 09:26:41AM +0200, Ralf Habacker wrote:
> >Hi,
> >
> >currently I'm compiling kde2 apps with cygwin and xfree and have a problem
> >loading dll's.
> >The problem is that on loading the app the windows runtime loader
> breaks with a
> >error message
> >"Die Anwendung konnte nicht richtig initialisiert werden (0xc0000142)"
> >
> >gdb says something about an unknown target exception:
> >--------------------------------------------------------
> >$ gdb -nw kicker.exe
> >GNU gdb 5.0 (20010428-1)
> >(gdb) r
> >Starting program: /opt/kde2/bin/kicker.exe
> >gdb: unknown target exception 0xc0000142 at 0x77fb00ac
> >
> >Program received signal ?, Unknown signal.
> >0x77fb00ac in ?? ()
> >(gdb) q
> >The program is running.  Exit anyway? (y or n) y
> >--------------------------------------------------------
> >
> >I have searched in the microsoft knowledge base, but what I found isn't very
> >much. :-(
> >
> >--------------------------------------------------------
> >Error Message:
> >(Application Error) The application failed to initialize properly
> (0xaddress ).
> >Click on OK to terminate the application.
> >User Action:
> >This is a Windows 2000 Executive STATUS error message. After you
> terminate the
> >application, try running it again. If this message reappears, contact the
> >supplier of the application.
> >--------------------------------------------------------
> >
> >What I have found that this problem occures while the dynamic linker
> (ntdll) is
> >working shown below.
> >The exception is raised by a "leave" instruction, but I
>
> Sounds like a corrupted stack.
>
You mean, because of loading so many dll's there is an application stack
overflow ?
As I know stack overflows depends on running app or cygwin code, but this will
be
done only when the run time loader is ready with relocating all dlls and have
called
the app entry point, which isn't true in this case (I have tested with setting a
breakpoint to the app entry point).
So this must be happens while runtime relocation.

Currently I'm without any idea, whats going wrong.

Any ideas, what to do ?

Ralf


- Raw text -


  webmaster     delorie software   privacy  
  Copyright © 2019   by DJ Delorie     Updated Jul 2019