ftp.delorie.com/archives/browse.cgi   search  
Mail Archives: cygwin-apps/2002/02/18/16:26:13

Mailing-List: contact cygwin-apps-help AT cygwin DOT com; run by ezmlm
Sender: cygwin-apps-owner AT cygwin DOT com
List-Subscribe: <mailto:cygwin-apps-subscribe AT cygwin DOT com>
List-Archive: <http://sources.redhat.com/ml/cygwin-apps/>
List-Post: <mailto:cygwin-apps AT cygwin DOT com>
List-Help: <mailto:cygwin-apps-help AT cygwin DOT com>, <http://sources.redhat.com/lists.html#faqs>
Delivered-To: mailing list cygwin-apps AT cygwin DOT com
Date: Mon, 18 Feb 2002 16:06:24 EST
To: cygwin-apps AT sources DOT redhat DOT com
Subject: Re: Setup
X-Mailer: Virtual Access by Atlantic Coast PLC, http://www.atlantic-coast.com/va
Message-Id: <VA.00000a82.00e1d48b@thesoftwaresource.com>
From: Brian Keener <bkeener AT thesoftwaresource DOT com>
Reply-To: bkeener AT thesoftwaresource DOT com
In-Reply-To: <015a01c1b886$622561b0$0200a8c0@lifelesswks>
References: <015a01c1b886$622561b0$0200a8c0 AT lifelesswks>

Robert Collins wrote:
> Ok, final feedback and bug-killing time folk.

I just built from CVS and the big thing I noticed in the past and still seems 
to be there has to do with doing an "Install from Local Directory" after doing 
the Download.  It appears the download is working fine but when I select 
Install from Local Directory if I select any package(s) for reinstall then 
setup seems to uninstall just fine but the Reinstall doesn't seem to do 
anything - my log doesn't seem to show any creations but it shows alot of 
unlinks for the removals.  I discovered this while researching another problem 
dealing with install from local directory where setup doesn't seem to install 
the last package selected for upgrade (as opposed to reinstall mentioned 
above).  It seems to download it fine or if I select install from the internet 
that also seems to work - I've been trying to debug it but my skills are 
beginner at best.  I can neither confirm or deny the upgrade problem at the 
moment but I just had the reinstall happen so I can confirm that one.

The other couple of things I've noticed are probably open for preference so I 
will throw them out for general consensus:

1) If I have a group of packages installed and I select the 
Test option to see what packages are available for in Test should all the 
packages I have installed that do not have a Test Version show Uninstall or 
should they should keep??  It is my contention that thy should show keep and 
not uninstall - unless I explicitly request uninstall.  

2) If I am doing and "Install from Local Directory" and the Source file does 
not exist in the Local path should the option for Source only or the Sources 
checkbox even be available?? It is my contention again that if the Sources 
cannot be found then the option should not exist.

Those are the few things I found - if you need a copy of my setup.log.full - 
just let me know.  I'll keep trying on the Reinstall to get a handle on what 
gives but if anyone has any clues you might want to fix it as opposed to 
waiting on me.

bk


- Raw text -


  webmaster     delorie software   privacy  
  Copyright 2019   by DJ Delorie     Updated Jul 2019