ftp.delorie.com/archives/browse.cgi   search  
Mail Archives: cygwin-apps/2002/02/22/22:37:35

Mailing-List: contact cygwin-apps-help AT cygwin DOT com; run by ezmlm
Sender: cygwin-apps-owner AT cygwin DOT com
List-Subscribe: <mailto:cygwin-apps-subscribe AT cygwin DOT com>
List-Archive: <http://sources.redhat.com/ml/cygwin-apps/>
List-Post: <mailto:cygwin-apps AT cygwin DOT com>
List-Help: <mailto:cygwin-apps-help AT cygwin DOT com>, <http://sources.redhat.com/lists.html#faqs>
Delivered-To: mailing list cygwin-apps AT cygwin DOT com
Message-ID: <017c01c1bc1a$741f8980$2400a8c0@mchasecompaq>
From: "Michael A Chase" <mchase AT ix DOT netcom DOT com>
To: <cygwin-apps AT cygwin DOT com>
Subject: Setup.exe subdirectories
Date: Fri, 22 Feb 2002 19:30:29 -0800
MIME-Version: 1.0
X-Priority: 3
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook Express 6.00.2600.0000
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000

I just tried downloading the new grep package in one setup.exe run and then
installing it in another.  Until I deleted the old setup.ini in the base
directory, I got message IDS_OLD_SETUPINI when I tried to install from the
local directory.

It looks like the setup.ini routines in ini.cc and iniparse.y are
overwriting setup_timestamp and setup_version with the last setup.ini file
read.  If that happens to be the newest, everyone is happy.  If it isn't
things could be confused.

Would it be worthwhile for me to try to make sure only the newest setup.ini
gets used?
--
Mac :})
** I normally forward private questions to the appropriate mail list. **
Ask Smarter: http://www.tuxedo.org/~esr/faqs/smart-questions.html
Give a hobbit a fish and he eats fish for a day.
Give a hobbit a ring and he eats fish for an age.



- Raw text -


  webmaster     delorie software   privacy  
  Copyright 2019   by DJ Delorie     Updated Jul 2019