ftp.delorie.com/archives/browse.cgi   search  
Mail Archives: cygwin-apps/2002/06/09/09:34:31

Mailing-List: contact cygwin-apps-help AT cygwin DOT com; run by ezmlm
Sender: cygwin-apps-owner AT cygwin DOT com
List-Subscribe: <mailto:cygwin-apps-subscribe AT cygwin DOT com>
List-Archive: <http://sources.redhat.com/ml/cygwin-apps/>
List-Post: <mailto:cygwin-apps AT cygwin DOT com>
List-Help: <mailto:cygwin-apps-help AT cygwin DOT com>, <http://sources.redhat.com/lists.html#faqs>
Mail-Followup-To: cygwin-apps AT cygwin DOT com
Delivered-To: mailing list cygwin-apps AT cygwin DOT com
Date: Sun, 9 Jun 2002 15:33:57 +0200
From: "Gerrit P. Haase" <gp AT familiehaase DOT de>
Reply-To: "Gerrit P. Haase" <gp AT familiehaase DOT de>
Organization: Esse keine toten Tiere
X-Priority: 3 (Normal)
Message-ID: <3971854641.20020609153357@familiehaase.de>
To: expat-discuss AT lists DOT sourceforge DOT net
CC: cygwin-apps AT cygwin DOT com
Subject: ITP: expat-1.95.3 for Cygwin
MIME-Version: 1.0

Hallo,

I intent to provide Expat as a new Cygwin package, though
with the released Expat version 1.95.3 it is a mess.
The provided libtool is version 1.4.  This is too old to
build DLL's on Cygwin.

We have a special version on Cygwin, that works, but it
should also work with libtool-1.4.2 which is the latest
release, though I used the libtool-devel that comes with
the Cygwin net release.

What is the problem with libtool 1.4.2?
Why is libtool 1.4 used?

The problem with installing when building outside the
sourcedir is still not completly resolved.  I sent
some patches which were *partially* applied?
So still expat.h isn't found during install if building
outside the sourcedir (also the manfile).

Also I wonder what is this in configure.in:

define([expat_version], ifdef([__gnu__],
                              [esyscmd(conftools/get-version.sh lib/expat.h)],
                              [1.95.x]))

there is no get-version.sh in the package included?


I relibtoolized with the Cygwin devel version.

I have packaged tarballs ready for use/review/upload.

The source includes a buildscript and the patch (5k),
just unpack it and run './expat-1.95.3-1.sh all'

This results in two tarballs, one with the source
and script and patch, one with the binaries, ready
to install them from / to prefix=/usr.

http://koeln.convey.de/cywgin/expat/expat-1.95.3-1-src.tar.bz2
http://koeln.convey.de/cywgin/expat/expat-1.95.3-1.tar.bz2
http://koeln.convey.de/cywgin/expat/setup.hint

For cygwin-apps, the setup.hint:
# Expat XML Parser
category: Doc Libs Text Devel Interpreters
requires: cygwin
sdesc: "XML parser library written in C"
ldesc: "Expat is an XML parser library written in C. 
It is a stream-oriented parser in which an application 
registers handlers for things the parser might find in 
the XML document (like start tags).
More details are available at http://www.libexpat.org/"


Gerrit
-- 
=^..^=

- Raw text -


  webmaster     delorie software   privacy  
  Copyright 2019   by DJ Delorie     Updated Jul 2019