ftp.delorie.com/archives/browse.cgi   search  
Mail Archives: cygwin-apps/2002/06/10/08:12:35

Mailing-List: contact cygwin-apps-help AT cygwin DOT com; run by ezmlm
Sender: cygwin-apps-owner AT cygwin DOT com
List-Subscribe: <mailto:cygwin-apps-subscribe AT cygwin DOT com>
List-Archive: <http://sources.redhat.com/ml/cygwin-apps/>
List-Post: <mailto:cygwin-apps AT cygwin DOT com>
List-Help: <mailto:cygwin-apps-help AT cygwin DOT com>, <http://sources.redhat.com/lists.html#faqs>
Mail-Followup-To: cygwin-apps AT cygwin DOT com
Delivered-To: mailing list cygwin-apps AT cygwin DOT com
From: "Robert Collins" <robert DOT collins AT syncretize DOT net>
To: <cygwin AT cygwin DOT com>, <cygwin-apps AT cygwin DOT com>
Subject: RE: New setup.exe snapshot 2.249.2.2
Date: Mon, 10 Jun 2002 22:12:00 +1000
Message-ID: <007501c21078$06e18c80$0200a8c0@lifelesswks>
MIME-Version: 1.0
X-Priority: 3 (Normal)
X-MSMail-Priority: Normal
In-reply-to: <215445849.20020610133633@syntrex.com>
Importance: Normal
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000


> -----Original Message-----
> From: Pavel Tsekov [mailto:ptsekov AT syntrex DOT com] 
> Sent: Monday, 10 June 2002 9:37 PM
> To: Robert Collins
> Cc: cygwin AT cygwin DOT com
> Subject: Re: New setup.exe snapshot 2.249.2.2
> 
> 
> Hello Robert,
> 
> Monday, June 10, 2002, 12:33:15 PM, you wrote:
> 
> RC> This snapshot update should fix the crash caused by a 
> setup.ini at the
> RC> top of the local cache dir.
> 
> It fixes it for me! :)
> 
> RC> Please hit on this and report any further errors.
> 
> This is not an error though it prevents me effectively from 
> working with the
> installer. There is something wrong with the wizard. Till the 
> introduction
> of the embedded PickView it was not so disturbing, but now .... The
> control is not entirely visible within the page i.e. it extends beyond
> the right and the bottom boundaries of the property page. This makes
> it impossible to use the scroll bars and I haven't found a way to
> scroll with the keyboard :(
> 
> The problem which I experienced before and continue to experince is
> that the installer uses bold fonts for the text of the controls. It
> seems also that the controls themselfs are not designed to fit in the
> pages i.e. most controls extend beyond the right or the bottom of the
> page - as in the chooser case. I don't see the place where this is
> done programmatically in the code so I assume it's either 
> windres or my
> WinXP. I tried another installer which performed this bad too - all
> fonts are bold, too large controls - so I assume it is 
> actually the WinXP.
> Strange enough, dialog boxes from various applications I've 
> checked have
> correct fonts. I have tried to change the font for the 
> controls manually
> in the code and it worked fine.
> 
> Does anyone experience the same behaviours on their XPs ?

I'm on XPPro, it works fine for me here. You'll need to step into the
sizing logic to see where the wrong metrics are returned, and then I may
be ablet o help. Also a screen dump would be useful.

PS. Followup to cygwin-apps please.

Rob

- Raw text -


  webmaster     delorie software   privacy  
  Copyright 2019   by DJ Delorie     Updated Jul 2019